5588葡京线路不同VLAN之间彼此通信

前话

我们常常到机房上课,想必对机房后那层叠的跟DVD一样的机器发出记忆吧,那些不畏交换机。

5588葡京线路 1

各一样摆旷日持久都是同样浅我挑战,而人生就是是急需不停的去挑战。

交换机作用是什么?

本身这里度娘一下:

交换机(Switch)意为“开关”是平种用于电(光)信号转发的网设施。它可以吗连抱交换机的肆意两独网络节点提供独享的电信号通路。

说简单点,就是也主机里创造通信道路的机械,如下图,各主机连接和个交换机,且IP在同一网段,在同一VLAN,他们是得并行通信的,他们即使大概组合了一个局域网。

5588葡京线路 2

多少人迅速,有些人格外缓慢,但无是具有快的口,最后实在是神速,也非是富有慢的食指,最后审是很缓慢。

才提到了vlan,vlan又是呀吧?

相同度娘一下:

VLAN(Virtual Local Area Network)的国语名也”虚拟局域网”。
虚拟局域网(VLAN)是千篇一律组逻辑上的配备及用户,这些装备以及用户并无为物理位置的限制,可以根据效益、部门和运用等要素将其组织起,相互之间的通信就象是她在和一个网段中相同,由此得名虚拟局域网。VLAN是一律种比较新的技术,工作以OSI参考模型的第2层和第3叠,一个VLAN就是一个广播域,VLAN之间的通信是透过第3重合的路由器来好的。与民俗的局域网技术并行较,VLAN技术更为灵敏,它有着以下优点:
网络设施的运动、添加和修改的保管支出减少;可以控制播放活动;可增长网络的安全性。
以处理器网络中,一个次交汇网络好给细分为多只例外之广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同之广播域是互隔离的。不同的广播域之间想要通信,需要通过一个或者多独路由器。这样的一个广播域就称为VLAN。

自己个人理解为,VLAN就是将同久很马路用隔离带分成基本上长达小街道之技能。
假如顾的是,每条小街道中间是免能够相通之,图示如下:

5588葡京线路 3

在交换机中得以上加VLAN和装置端口处哪个VLAN,我们用前大概局域网示例来讲解:

5588葡京线路 4

点一样贵主机 PC0 处于VLAN 1 ,下面两独主机 PC1 和 PC2 处于 VLAN 2
,三玉主机的IP处于同一网段。
PC0 接抱交换机端口 Fa0/1 ,PC1 接抱交换机端口 Fa0/2 ,PC2 接抱交换机端口
Fa0/3 。
但由于VLAN不同,PC0 不能和 PC1 PC2 通信。
下面两光主机 PC1 和 PC2 的IP同网段,也和处 VLAN 2
,因此就有限雅主机可以相互通信。

交换机配置过程如下:

Switch> enable                                  //进入特权模式
Switch# vlan database                           //进入vlan数据库
Switch(vlan)# vlan 2                            //添加一个vlan,vlan号为 2 。默认所有端口处于vlan 1 ,因此本例子只需添加添加 vlan 2
Switch(vlan)# exit                              //退出 vlan数据库
Switch# configure terminal                      //进入全局配置模式
Switch(config)# interface FastEthernet 0/2      //进入端口Fa0/2设置
Switch(config-if)# switchport access vlan 2     //设置端口Fa0/2处于vlan 2,默认所有端口处于vlan 1 ,所以本实例不用对端口Fa0/1设置vlan
Switch(config-if)# exit                         //退出端口Fa0/2设置
Switch(config)# interface FastEthernet 0/3      //进入端口Fa0/3设置
Switch(config-if)# switchport access vlan 2     //设置端口Fa0/3处于vlan 2
Switch(config-if)# end                          //设置完成退出

那我们的重要性问题来了,不同VLAN之间该怎么进行通信为?下面我们开主题!

启主题前,先上同样布置自己本着学校机房网络的图示 >_< ,有错请轻喷。

5588葡京线路 5


今非昔比VLAN之间相通信

交换机vlan有什么用吧?谷歌娘度娘会暨你说啊降低一长长的网络线的网风暴提高利用率啊什么的。
本身目前为止觉得挺有因此底凡,实现通过不同vlan通信可以假设不同网络段子的主机能够进行通信。
地方就词话来接触长,我举个例证吧,比如我们知道,若子网掩码为 255.255.255.0
,IP为 192.168.10.100 的主机不可知和 IP为 192.168.20.100
的主机进行通信,它们简单免以同一子网。

那么有什么点子化解呢?有平等栽是经路由器,路由器一般生两三只端口,接入子网的端口设置为子网的网关即可兑现两个子网的通信,如下图所示:

5588葡京线路 6

落得图真可简单贵不同子网的主机的通信问题,那么问题而来了,两只子网各有3玉抑再次多主机为?好吧,加上个交换机,一华交换机和主机组成一个子网,子网设置网关为搭抱的路由器端口IP,如下图所示:

5588葡京线路 7

高达图为确确实实可使有限只例外子网多贵主机进行通信,但是一般一个交换机发24个端口,一个子网两三台主机那也尽浪费了。

倘若忽视成本这方案得以通过,那么问题还要来了,如果有3单子网或者再次多之子网呢,主机为再也多吧?

平宝路由器也即那么两三单端口哦。也许大家照面说,加多几只交换机,加多几独路由器来组网。
这种粗暴式的经增加硬件成本组网肯定会导致后面多的题材,

现实什么严重问题也?大家有钱可以购置来组网试试。

感觉钱就是极端严重的问题了~~~

VLAN技术之出现,可以大大减少开销成本,高大上之技艺很省钱!

开心的 🙂


无异于的行程,同样的路线,不同之肤色,不同之心情。

落实不同VLAN之间通信的点滴栽标准措施

有些人是真正快,快到公怀疑人生。有些人并无是真的的不胜缓慢,他们只是为徐也上,一步一个脚印罢了。

单臂路由

教授单臂路由前先行瞧双臂路由(好像是这样吃吧 =_= ) ,如下图:

5588葡京线路 8

上图一个VLAN连接一个路由器端口,两三个子网路由器还足以应付,但是子网更多时,路由器端口就不够用了。

从而路由器端口多了一个子端口技术,来实现单臂路由。

路由器只待一个端口与交换机进行连接,并安装该端口的子端口对应之vlan信息,而交换机只需要将接连路由器的端口设置vlan模式呢trunk即可。

经单臂路由实现不同vlan通信,可以省去路由端口消耗,单臂路由图解如下:

5588葡京线路 9

洋洋丁在赛前提问我北马好走上前小?我中心没的的直接无敢说,只能说完赛就好。完赛肯定是能够完赛,不敢说目标不仅仅是顾虑好开不顶,而是不乐意去吃自己设定目标。跑马就东西和平常之目标是休雷同的,因为并无是说若想就真的好完成的。同样多都是量到质的蜕变,但同其余的事物是当真没可比性的。

交换机设置

本着主机VLAN的剪切的一对省略

Switch> enable
Switch# configure terminal
Switch(config)# interface FastEthernet 0/24             //Fa0/24端口连接路由器
Switch(config-if)# switchport mode trunk                //设置该端口vlan模式为trunk
Switch(config-if)# switchport trunk allowed vlan all    //设置该端口trunk模式下接收所有vlan线路的信息
Switch(config-if)# end                                  //完成设置退出

留神,若交换机端口未启动,需要上及无启动之端口,然后键入命令
no shutdown 对那进展启动。

辩论及可进330之自家,在事实上比里,没有同涂鸦实现了,甚至连4都未曾排除了。每次比里,按前半程的速时间结比,完成目标定妥妥的,但老是交最终还见面面世形形色色的幺蛾子,最沉痛莫过于各式各样的痉挛。

路由器安装

路由器端口 Fa0/0连接交换机,该端口无苟装IP地址。

Router> enable
Router# configure terminal
Router(config)# interface FastEthernet 0/0
Router(config-if)# no shutdown                                  //启动Fa0/0端口

Router(config-if)# interface FastEthernet 0/0.1                 //添加设置Fa0/0端口的子端口Fa0/0.1
                                                                //同理Fa0/1端口的子端口可以为Fa0/1.1,Fa0/0.6等

Router(config-subif)# encapsulation dot1Q 1                     //对该子端口Fa0/0.1进行802.1q协议的封装
                                                                //后面的数字 1 代表是的侦听VLAN号为 1 的传输数据

Router(config-subif)# ip address 192.168.10.1 255.255.255.0     //设置该子端口Fa0/0.1的IP和子网掩码
Router(config-subif)#no shutdown                                //启动该子端口

Router(config-if)# interface FastEthernet 0/0.2                 //添加设置Fa0/0端口的子端口Fa0/0.2
Router(config-subif)# encapsulation dot1Q 2                     //对该子端口Fa0/0.2进行802.1q协议的封装

Router(config-subif)# ip address 192.168.20.1 255.255.255.0     //设置该子端口Fa0/0.2的IP和子网掩码
Router(config-subif)# no shutdown                               //启动该子端口

Router(config-subif)# end                                       //完成设置退出

Router# show ip route                                           //查看路由信息

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/0.1
C    192.168.20.0/24 is directly connected, FastEthernet0/0.2   

最后转手输出路由信息,说明设置成。

C    192.168.10.0/24 is directly connected, FastEthernet0/0.1
C    192.168.20.0/24 is directly connected, FastEthernet0/0.2   

实质上,有时候你见面怀念,我们跑步干啊?跑那么快,追求那些所谓的配速又得能比来什么?

其三层交换机

平常交换机没有路由功能,而三层交换机可以看成普通交换机和路由器合二为同样之机。
所以三层交换机具有路由功能,而且三层交换机的端口是vlan端口。

老三层交换机的利用特别灵活,我此说简单栽:

  • 主机——三层交换机——主机
  • 长机——交换机——三层交换机——交换机——主机

若飞的更抢,肯定也走不了肯尼亚、埃塞俄比亚齐的那些小黑们。有时候并无是若无把、不研究,而是你得使一口咬定理想和现实里的距离,很多事情若真的就是比较非了的。

主机——三层交换机——主机

图解如下:

5588葡京线路 10

既是您比非了,那为何非放开轻松,好好的失去分享比赛之野趣、赛道的风光啊?

老三层交换机设置

其三层交换机增加vlan和针对性主机的vlan划分有简易。

Switch> enable
Switch# configure terminal

Switch(config)#ip routing                                   //启动三层交换机路由功能

Switch(config)# interface Vlan 1                            //添加设置关联Vlan号为1的路由端口
Switch(config-if)# ip address 192.168.10.1 255.255.255.0    //为该路由端口设置IP和子网掩码
Switch(config-if)# no shutdown                              //启动该端口
Switch(config-if)# exit                                     //退出该端口

Switch(config)# interface Vlan 2                            //添加设置关联Vlan号为2的路由端口
Switch(config-if)# ip address 192.168.20.1 255.255.255.0    //为该路由端口设置IP和子网掩码
Switch(config-if)# no shutdown                              //启动该端口
Switch(config-if)# exit                                     //退出该端口

Switch(config)# interface Vlan 3                            //添加设置关联Vlan号为3的路由端口
Switch(config-if)# ip address 192.168.30.1 255.255.255.0    //为该路由端口设置IP和子网掩码
Switch(config-if)# no shutdown                              //启动该端口
Switch(config-if)# end                                      //完成退出

Switch# show ip route                                       //查看路由信息

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, Vlan1
C    192.168.20.0/24 is directly connected, Vlan2
C    192.168.30.0/24 is directly connected, Vlan3

出口以上路由于信息表示设置成 🙂


长机——交换机——三层交换机——交换机——主机

图解如下:

5588葡京线路 11

通常交换机添加vlan和针对主机vlan划分有简练。
假设普通交换机连接三层交换机的端口已装vlan模式为trunk,连接三层交换机后,三层交换机连接普通交换机的端口其模式会自行安装为trunk。

当路俩旁的观众们为我们加油助威的喊叫“你们还是好样的、你们还是勇于”的时,你是不是会觉得好偶然确实是深之深,非常的决定呢?

通常交换机设置(示例两单普通交换机设置同一)

Switch> enable
Switch# configure terminal
Switch(config)# interface FastEthernet 0/24
Switch(config-if)# switchport mode trunk        //设置Fa0/24端口vlan模式为trunk
Switch(config-if)#end

当你能够把长期跑下去,你实在就是坏之牛逼了。因为你明白并无是啊人且得以走了马拉松的,也并无是呀想走就能走的。而而也挺轻松的拿老给走下来了,你还见面担心无能随便用么?

其三层交换机设置(与前方的接近)

Switch> enable
Switch#vlan database
Switch(vlan)# vlan 2                                        //添加vlan 2
Switch(vlan)# exit

Switch# configure terminal

Switch(config)#ip routing                                   //启动三层交换机路由功能

Switch(config)# interface Vlan 1                            //添加设置关联Vlan号为1的路由端口
Switch(config-if)# ip address 192.168.10.1 255.255.255.0    //为该路由端口设置IP和子网掩码
Switch(config-if)# no shutdown                              //启动该端口
Switch(config-if)# exit                                     //退出该端口

Switch(config)# interface Vlan 2                            //添加设置关联Vlan号为2的路由端口
Switch(config-if)# ip address 192.168.20.1 255.255.255.0    //为该路由端口设置IP和子网掩码
Switch(config-if)# no shutdown                              //启动该端口
Switch(config-if)# end                                      //退出该端口

Switch# show ip route                                       //查看路由信息

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, Vlan1
C    192.168.20.0/24 is directly connected, Vlan2

出口以上路由于信息表示设置成 🙂


心态很多时刻实在特别重要,我联合底平抑在配速稳固在520~535中,如果依照是配速坚持的蒸发下去是迟早能前进4底,当然理论及是绝非问题的,但我们连会忽略一些现实的物,那就是是每次上的时日及奇怪之发生,一路臻遇到补为点便止吃喝,而北马这次的补偿点数比以往的外赛事还要多之大都,也用造成在补偿上面浪费了太多之年月,太多之停下导致身体的免凑巧,在30km后初步压非停歇配速,也开掉速了。虽然不是最最严重,但35km后哪怕从头各种小抽筋,从而造成配速掉的未能够再次不见。虽然说就无异次等或抽筋了,虽然知情是以跑量不够,但和去年南马相比,真的好极多矣。有时候你实在会认为那个满足。

感想

总归这点内容写了一样天了,累但是格外满足,谢谢阅读~~~

靶是因此来过的,虽然不必然每次设定的目标还好好,但您如掌握各个一样不良的那一点点腾飞都是你在慢慢变的脍炙人口之最好好之证实。

丁可比人口真的会气死人,我们且非是众人眼中的别人家的孩子。就使条条大路通罗马,可多人口之舍本来就是停下在罗马。如果您切莫要失去攀比,非要是与自己死般的苦苦的磨难自己,那又是何苦呢?

人生最为老之对方不是冤家,而是自己。不少时节如果较真正如与自己比就吓,当您瞧自己同不善同不善的前进,不断的基础代谢着PB,你莫觉得就正是大团结拼命的结果也?很多人数极力的回报都于无意一步步之显现出来的。所以,千万不要放弃自己,你在日渐的易的美妙。

坚持不懈即是常胜,还好自未曾放弃。

当你看来前方不远处即是终端的时光,真的是雅深的喜气洋洋,浑身都见面太之自由自在,那是坐若相了希望,看到了曙光。虽然您早都乏力提不从力气又失加油了,但若可依然坚持坚持根据向终极,你虽老想放弃走及顶点,但当你想到如果您坚持住就是能叫成绩未必那么差的时,你真正好了。

42.195公里,对于许多口的话是个大惊失色的数字,而自于当下四十几近公里里可的确不亮该怎么去写,北京之天以17如泣如诉当天可莫名的好,阳光非常的明媚,导致众多口给暴晒的伪不成样,当然我也是于曝黑的同样员。

见到了过多丁中途受伤,也赶上了森总人口于相距终点三四公里处坐身体无正而最后弃赛。如果未是赖在高中的治疗扶助我怀念我呢可能会见成为他们受的如出一辙各项。但当我抽筋坐在路边简单拉伸过来的时刻,我载脑子想的也仅仅是若咬牙,不可知放弃,哪怕走自己倒吗得要活动至终点。

信心能给你坚持继续的错过坚持,心态会吃你放轻松身心的失完比赛,而人的状态是若坚持到终极的极致老驱动力。

当赛发枪起跑前,三万大抵曰健儿站在天安门广场达标联手唱国歌时,你莫掌握内心是出多么的激动与自豪。

当你飞了全程,拿起奖牌,忍不住亲咬一人底时刻,你真正不知道是生多的快。

列一样街旷日持久都是一模一样不善我挑战,而人生就是是急需不停的去挑战。

休息步迈进,以减缓也上,脚踏实地,坚持即是赢。

究竟没会pb,还吓不危害完赛